eric ide

Issue113

Classification
Title: When running a pyside script, the DebugClient.py script fails with error 4 in libc-2.15.so
Type: crash Product: eric4
Process
Priority: high    
Status: closed Resolution: will not fix
Superseder: Nosy List: a.atalla, dave, detlev
Assigned to: detlev Keywords:

Created on 2013-08-28.16:38:22 by dave, last changed by detlev.

Messages (4.0)
msg681 (view) Author: detlev Date: 2015-09-07.17:15:40
Seems to be PySide.
msg437 (view) Author: detlev Date: 2013-11-23.16:51:49
It seems to happen as soon as an QApplication object is created. Unfortunately I 
have no idea why it behaves like that. Creating a PyQt4 QApplication object works 
fine. The debugger backend does not do anything special for PySide here.
msg426 (view) Author: a.atalla Date: 2013-10-16.19:21:04
i confirm this issue too for both Eric4  & Eric5  in  ubuntu 13.10
msg418 (view) Author: dave Date: 2013-08-28.16:38:22
When executing any pyside (1.1.0-1) script under Eric4 (4.5.14) on Ubuntu 12.04,
nothing is executed, and the /var/log/syslog shows "python[18001]: segfault at 0
ip 00007fea3366f111 sp 00007fff50013d58 error 4 in
libc-2.15.so[7fea335e6000+1b5000]". This is caused by something in
"/usr/lib/python2.7/dist-packages/eric4/DebugClients/Python/DebugClient.py".

Plain Python and PyQT scripts run fine.

I am warming up to Eric as I learn more Python scripting and this one problem
really causes an issue in my day. Any help would really be appreciated.
History
Date User Action Args
2015-09-07 17:15:40detlevsetstatus: open -> closed
resolution: will not fix
messages: + msg681
message_count: 3.0 -> 4.0
2013-11-23 16:51:50detlevsetstatus: new -> open
assignedto: detlev
messages: + msg437
message_count: 2.0 -> 3.0
nosy: + detlev
2013-10-16 19:21:04a.atallasetmessage_count: 1.0 -> 2.0
nosy: + a.atalla
messages: + msg426
2013-08-28 16:38:22davecreate