eric ide

Issue208

Classification
Title: Unhandled import error on "import win32api" (it's on sys.path)
Type: behavior Product: eric6
Process
Priority: high    
Status: closed Resolution: works for me
Superseder: Nosy List: detlev, jmatos
Assigned to: Keywords:

Created on 2016-10-23.12:04:31 by jmatos, last changed by jmatos.

Files
File Name Uploaded Description Remove
Eric6Error.jpg jmatos, 2016-10-23.12:04:31
Messages (3.0)
msg777 (view) Author: jmatos Date: 2016-10-24.01:43:31
The problem also occurs in a plain Python installation.

The solution is simple.
Just copy the 2 DLLs from
C:\WinPython35\python-3.5.2\Lib\site-packages\pywin32_system32 to
C:\WinPython35\python-3.5.2\Lib\site-packages\win32.

For the plain Python the solution is the same (with the obvious change in paths).
msg775 (view) Author: detlev Date: 2016-10-23.15:14:46
The issue is reproducible with WinPython. I tested it with Anaconda as well and 
it works fine. It is probably related to setting some environment variables done 
by the myriad of WinPython scripts.
msg774 (view) Author: jmatos Date: 2016-10-23.12:04:31
I use WinPython 3.5.2 and when running a simple py script:
import win32api
print('123')
everything runs in the Python shell, as it should.
However, if I try to run it in Eric6 it always returns an "unhandled import error".
I checked the sys.path and everything seems ok.
History
Date User Action Args
2016-10-24 01:43:31jmatossetmessage_count: 2.0 -> 3.0
messages: + msg777
2016-10-24 01:39:58jmatossetmessage_count: 3.0 -> 2.0
messages: - msg776
2016-10-23 16:45:41jmatossetstatus: open -> closed
resolution: works for me
messages: + msg776
message_count: 2.0 -> 3.0
2016-10-23 15:14:46detlevsetmessage_count: 1.0 -> 2.0
nosy: + detlev
messages: + msg775
2016-10-23 15:13:16detlevsetstatus: new -> open
2016-10-23 12:04:31jmatoscreate