eric ide

Issue217

Classification
Title: reCAPTCHA doesn't work on some sites
Type: behavior Product: eric6
Process
Priority: high    
Status: closed Resolution: invalid
Superseder: Nosy List: detlev, shao.lo
Assigned to: Keywords:

Created on 2016-12-18.18:27:01 by shao.lo, last changed by detlev.

Messages (6.0)
msg807 (view) Author: detlev Date: 2016-12-20.09:30:24
Issue caused by QtWebKit.
msg806 (view) Author: shao.lo Date: 2016-12-19.23:16:10
I didn't realize what a mess qtwebkit is at this moment.  On a clean ubuntu
system with pip3 install of pyqt5 the webengine version of eri6 browser does
indeed work.  Sorry for the bad report.
msg805 (view) Author: shao.lo Date: 2016-12-18.18:54:04
Using the eric6 QtWebKit browser.
msg804 (view) Author: shao.lo Date: 2016-12-18.18:50:51
Python Version: 3.5.2
Qt Version: 5.6.1
PyQt Version:  5.7.0
eric6-16.12
Linux 4.8.0-30-generic #32-Ubuntu SMP Fri Dec 2 03:43:27 UTC 2016 x86_64 x86_64
x86_64 GNU/Linux
msg803 (view) Author: detlev Date: 2016-12-18.18:40:56
Cannot reproduce the issue. I would need more information about versions of 
software used (Qt, Python, eric, ...).
msg802 (view) Author: shao.lo Date: 2016-12-18.18:27:01
http://www.finalwebsites.com/demos/custom-captcha-image-script/
gets "Please upgrade to a supported browser to get a reCAPTCHA challenge."

https://www.google.com/recaptcha/api2/demo
works, though the alternate image based challenge is generated and the
checkboxes are hard to see.
History
Date User Action Args
2016-12-20 09:30:24detlevsetstatus: open -> closed
resolution: invalid
messages: + msg807
message_count: 5.0 -> 6.0
2016-12-19 23:16:10shao.losetmessage_count: 4.0 -> 5.0
messages: + msg806
2016-12-18 18:54:04shao.losetmessage_count: 3.0 -> 4.0
messages: + msg805
2016-12-18 18:50:51shao.losetstatus: pending -> open
message_count: 2.0 -> 3.0
messages: + msg804
2016-12-18 18:40:56detlevsetstatus: new -> pending
nosy: + detlev
messages: + msg803
message_count: 1.0 -> 2.0
2016-12-18 18:27:01shao.locreate