eric ide

Issue243

Classification
Title: Eric6 crash on Project update
Type: crash Product: eric6
Process
Priority: high    
Status: closed Resolution: fixed
Superseder: Nosy List: detlev, tomigo
Assigned to: detlev Keywords:

Created on 2017-08-07.16:22:00 by tomigo, last changed by tomigo.

Files
File Name Uploaded Description Remove
E5ErrorMessage.py detlev, 2017-08-09.15:10:49 Changed E5Gui/E5ErrorMessage.py
eric6.py detlev, 2017-08-08.08:56:59 Changed main script
eric6.txt tomigo, 2017-08-07.16:22:00 Command Line suysout
eric6_error.log tomigo, 2017-08-08.16:38:30
Messages (8.0)
msg906 (view) Author: tomigo Date: 2017-08-09.22:50:12
Thank you! That corrected both problems I was having in the application! 
Everything appears to be working again!
msg905 (view) Author: detlev Date: 2017-08-09.15:10:49
Please replace the file E5Gui/E5ErrorMessage with the uploaded variant. The issue 
seems to be caused by a bug in openSUSE 42.3 KDE/Qt integration. When a warning 
dialog pops up about some locale/i18n stuff, just select the "Don't show this 
again button" and it will be gone forever. There were similiar issues in the 
past.

Please report back.
msg904 (view) Author: tomigo Date: 2017-08-08.16:45:16
Oh, I do see a new line in sysout in the middle of the many lines that match the
following first line:

File "/usr/lib64/python3.4/site-packages/eric6/E5Gui/E5ErrorMessage.py", line
114 in messageHandler
File "/usr/lib64/python3.4/site-packages/eric6/eric6.py", line 205 in excepthook

Note that when I attempt to run eric6 now, I get a notice about the previous
crash, and I have to click ignore and delete since I am not able to config the
email information, and then eric6 crashes and closes after I click "No" to the
question of whether I want to restore the crashed session.
msg903 (view) Author: tomigo Date: 2017-08-08.16:38:30
Sorry, my mistake, I had recompiled using the old code.  That is taken care of
now, but I still see little difference in sysout.  I am attaching the log file
from ~/.eric6 directory.
msg902 (view) Author: detlev Date: 2017-08-08.16:07:19
There should be a log file in the directory ~/.eric6. This would contain the error 
information. It is strange, that the script fails in exactly the same way. Please 
double check, that the installed script (eric6.py) is actually the one downloaded 
from this issue.
msg901 (view) Author: tomigo Date: 2017-08-08.14:30:28
Thanks for the attempt.  I copied the new module over the previous one, and
reran the install.py to recompile everything, but I see no difference in the
information written to sysout.  All module names and line numbers are the same
as what I sent in the previous eric6.txt file.  Is there something else I can
send that would help you debug this?
msg900 (view) Author: detlev Date: 2017-08-08.08:56:59
The issue is probably a missing xml.sax.saxutils module. This would trigger an 
import error, which calls the excepthook() function and the code runs in circles. 
The attached main script (eric6.py) get rid of this. That way the issue triggering 
the excepthook() method should become visible.
msg899 (view) Author: tomigo Date: 2017-08-07.16:22:00
Just finished installing Eric6-17.08 on openSUSE Leap 42.3 and was going through
the initial startup configurations steps.  When I got to the "Project"
sub-category on the list tree, and clicked on "Multiproject" the application
crashes.  I had similar issues when I was using Eric5 and attempted to add new
files to an existing project.  I have attached the sysout information that
appears when running it from command line as well as the crash report.
History
Date User Action Args
2017-08-09 22:50:12tomigosetstatus: open -> closed
resolution: fixed
messages: + msg906
message_count: 7.0 -> 8.0
2017-08-09 15:10:49detlevsetfiles: + E5ErrorMessage.py
message_count: 6.0 -> 7.0
messages: + msg905
2017-08-08 16:45:16tomigosetmessage_count: 5.0 -> 6.0
messages: + msg904
2017-08-08 16:38:30tomigosetfiles: + eric6_error.log
message_count: 4.0 -> 5.0
messages: + msg903
2017-08-08 16:07:19detlevsetmessage_count: 3.0 -> 4.0
messages: + msg902
2017-08-08 14:30:28tomigosetmessage_count: 2.0 -> 3.0
messages: + msg901
title: Eric6 crahs on Project update -> Eric6 crash on Project update
2017-08-08 08:56:59detlevsetstatus: new -> open
files: + eric6.py
nosy: + detlev
messages: + msg900
message_count: 1.0 -> 2.0
assignedto: detlev
2017-08-07 16:22:00tomigocreate