eric ide

Issue56

Classification
Title: Selected text gets deleted when switching to another file/module and back
Type: behavior Product: eric4
Process
Priority: high    
Status: closed Resolution: works for me
Superseder: Nosy List: beliar, detlev
Assigned to: detlev Keywords:

Created on 2012-03-29.13:47:16 by beliar, last changed by beliar.

Messages (12.0)
msg196 (view) Author: beliar Date: 2012-03-31.12:53:22
Ok, now I am confused.

The problem only happens when I start eric4 or eric5 from a terminal. Then it
doesn't matter if I use gnome3, unity or gnome-classic. If I start eric5 from
the menu THEN the problem is gone.

Nevertheless, if remember to not start eric from a terminal its no problem for me.
msg195 (view) Author: beliar Date: 2012-03-31.12:04:04
I have to correct myself, its not unity, its gnome-shell (gnome3), that works.
Unity has the same problem as gnome-classic.
msg194 (view) Author: detlev Date: 2012-03-31.12:00:49
Please report the issue on the QScintilla mailing list.
msg193 (view) Author: beliar Date: 2012-03-31.11:43:55
You are right, it seems that the problem is with gnome-classic. When I switch
back to unity the problem is gone.
msg192 (view) Author: detlev Date: 2012-03-31.11:33:26
I retested it on Kubuntu 11.10 and it works ok. The fact that both eric variants
behave identical on your system indicate, that it is related to some library.
What desktop are you using? In the past there had been issues with QScintilla
and Gnome. Would it be possible to switch to KDE and retest?
msg191 (view) Author: beliar Date: 2012-03-31.11:19:25
Ok, I updated it, but the problem is still there.

The versions are now as follows:

Version Numbers
Python
2.7.2+
Qt
4.7.4
PyQt
4.8.5
sip
4.13.2
QScintilla
2.6.1
eric4
4.5.1 (r4294)

Btw., I tested eric5, to see if the problem is there too. And it has the same
problem.
msg190 (view) Author: detlev Date: 2012-03-31.09:06:47
Your QScintilla installation is fairly old and might contain a bug (I think I
remember something like that). Please upgrade to the latest release (2.6.1).
msg189 (view) Author: beliar Date: 2012-03-30.11:23:22
Ok, here is the info:

Version Numbers
Python
2.7.2+
Qt
4.7.4
PyQt
4.8.5
sip
4.12.4
QScintilla
2.4.5
eric4
4.5.1 (r4294)
msg188 (view) Author: detlev Date: 2012-03-30.10:50:18
Maybe the issue is related to the libraries used by eric4. Please give version 
info (see the versions dialog of the help menu).
msg187 (view) Author: beliar Date: 2012-03-30.10:06:23
Well, I guess I will have to wait until it magically fixes itself or something then.
msg186 (view) Author: detlev Date: 2012-03-29.17:33:53
I cannot reproduce the issue on openSUSE 12.1 nor on Windows nor on Mac OS X.
msg185 (view) Author: beliar Date: 2012-03-29.13:47:16
Steps:

1. Select any text
2. Switch to another file/module
3. The text that was selected gets deleted.

While one can undo the deletion this is quite annoying. Also one might not
notice the deletion until much later.

Eric version: Eric4 4.5.1
OS: Ubuntu Oneiric
History
Date User Action Args
2012-03-31 12:53:22beliarsetmessage_count: 11.0 -> 12.0
messages: + msg196
2012-03-31 12:04:04beliarsetmessage_count: 10.0 -> 11.0
messages: + msg195
2012-03-31 12:00:49detlevsetmessage_count: 9.0 -> 10.0
messages: + msg194
2012-03-31 11:43:55beliarsetmessage_count: 8.0 -> 9.0
messages: + msg193
2012-03-31 11:33:26detlevsetmessage_count: 7.0 -> 8.0
messages: + msg192
2012-03-31 11:19:25beliarsetmessage_count: 6.0 -> 7.0
messages: + msg191
2012-03-31 09:06:47detlevsetmessage_count: 5.0 -> 6.0
messages: + msg190
2012-03-30 11:23:23beliarsetmessage_count: 4.0 -> 5.0
messages: + msg189
2012-03-30 10:50:18detlevsetmessage_count: 3.0 -> 4.0
messages: + msg188
2012-03-30 10:06:23beliarsetmessage_count: 2.0 -> 3.0
messages: + msg187
2012-03-29 17:33:53detlevsetstatus: open -> closed
resolution: works for me
messages: + msg186
message_count: 1.0 -> 2.0
2012-03-29 17:32:54detlevsetstatus: new -> open
assignedto: detlev
nosy: + detlev
2012-03-29 13:47:16beliarcreate