eric ide

Issue99

Classification
Title: Selected text is deleted when switching focus between widgets
Type: behavior Product: eric4
Process
Priority: high    
Status: closed Resolution: invalid
Superseder: Nosy List: detlev, nzh
Assigned to: detlev Keywords:

Created on 2013-03-21.18:00:30 by nzh, last changed by nzh.

Messages (5.0)
msg369 (view) Author: nzh Date: 2013-03-21.19:58:19
Removing "ibus" fixes the problem.
msg368 (view) Author: nzh Date: 2013-03-21.19:43:31
Ah, I finally found a bug report in the Debian system implying that this is due
to the package "ibus", which I installed on my system recently. Apparently this
causes a problem inside katepart. I'm trying to remove the package to see if it
fixed the problem...
msg365 (view) Author: detlev Date: 2013-03-21.18:26:50
Could this be a Debian "testing" issue? I cannot reproduce it over here. Tried
it on openSUSE 12.3 and Kubuntu 12.10. I don't have Debian around. The only
distro that comes close is Raspbian "Wheezy". eric works fine there on the
RaspBerry.
msg363 (view) Author: nzh Date: 2013-03-21.18:03:21
The environment versions I'm using are:
Python 2.7.3rc2
Qt 4.8.2
PyQt 4.9.3
sip 4.13.3
QScintilla 2.6.2
eric4 4.5.9 (r4427)

My environment is KDE 4.8.4 running on the Debian "testing" distribution. (Is it
"Wheezy" these days?)
msg362 (view) Author: nzh Date: 2013-03-21.18:00:30
When using the Find dialog, if you hit ESC to close the dialog, then any
highlighted text in the editor gets deleted. The same thing happens if I
highlight some text, switch to a different tab, and then when I return to the
tab with the highlighted text, it deletes the selection. However, if I highlight
some text, leave Eric4 so that a separate program has input focus, and then
return to Eric4, the highlighted text is *not* deleted. As far as I've seen,
this unwanted deleting behavior only happens between the find dialog and the
various file tabs open in the editor.
History
Date User Action Args
2013-03-21 20:22:38nzhsetstatus: open -> closed
resolution: invalid
2013-03-21 19:58:19nzhsetmessage_count: 4.0 -> 5.0
messages: + msg369
2013-03-21 19:43:31nzhsetmessage_count: 3.0 -> 4.0
messages: + msg368
2013-03-21 18:26:50detlevsetstatus: new -> open
assignedto: detlev
messages: + msg365
message_count: 2.0 -> 3.0
nosy: + detlev
2013-03-21 18:03:21nzhsetmessage_count: 1.0 -> 2.0
messages: + msg363
2013-03-21 18:00:30nzhcreate