eric ide

Issue124

Classification
Title: can't input Chinese??? I have allready installed the translation package.....
Type: feature request Product: eric5
Process
Priority: urgent    
Status: closed Resolution: rejected
Superseder: Nosy List: DEAGS3000, detlev, shanhu
Assigned to: detlev Keywords:

Created on 2014-01-12.06:00:26 by DEAGS3000, last changed by detlev.

Files
File Name Uploaded Description Remove
120140505222524.png shanhu, 2014-05-05.14:26:31 eric5 cant't input chinese.
Messages (15.0)
msg495 (view) Author: detlev Date: 2014-05-05.16:48:36
The latest PyQt4 installer includes QScintilla 2.8.1, which got support for input 
methods (see msg464). That's why it works for the latest PyQt4.

Issue closed because the reason is outside eric.
msg494 (view) Author: shanhu Date: 2014-05-05.15:08:58
It's PyQt4 problem!!! When I update the newest version PyQt4-4.10.4-gpl-Py3.3-
Qt4.8.5-x64.exe! Eric5 editor work fine! Before that I use PyQt4-4.10.3-gpl-Py3.3-
Qt4.8.5-x64.exe will result can't input use chinese input software!!!
msg493 (view) Author: shanhu Date: 2014-05-05.14:26:31
I updated to newest eric5-5.4.3 from eric5-5.3.1 today. Somehow chinese input 
software can't type any thing to the editor. Try to uninstall the newest to net 
older version, that's don't work again. For this reason I have to change to eric4 
in python 2.7.6 version  that's still working. so could help us solve this 
problem? thank u a lot.
msg464 (view) Author: detlev Date: 2014-01-26.15:03:55
Do other Qt applications (besides eric) have the same issue? You may try this 
with the example text editor of Qt/PyQt. It is possible, that your input method 
plug-in is not compatible with Qt. Another thing to note is, that QScintilla 
(the editor widget used by eric), just recently got support for input methods 
(as of 2.8.1 snapshots). Maybe it is a good idea, to ask for support in the eric 
and/or PyQt mailing lists.

Sorry for that.
msg463 (view) Author: DEAGS3000 Date: 2014-01-26.14:26:19
It isn't too diffcult.We inupt Chinese characters by American keyboard.If 
convenient,you can download a Chinese input method from here:  
http://pinyin.sogou.com/softdown.php?v=6.8&type=c&ref=indexbanner
msg462 (view) Author: detlev Date: 2014-01-26.09:56:36
Unfortunately I am not in a position to find the cause for your observation 
because I don't have a Chinese keyboard or know how to input Chinese characters 
using a normal keyboard.
msg461 (view) Author: DEAGS3000 Date: 2014-01-25.07:31:13
I found T can paste Chinese characters into Eric and they could be shown 
correctly.But I can't input them directly by typewriting.
msg458 (view) Author: detlev Date: 2014-01-13.17:25:49
How do other Qt/PyQt4 applications behave? If all inputs don't work I suspect 
something else is wrong.
msg457 (view) Author: DEAGS3000 Date: 2014-01-13.12:00:12
I mean thr command line of 
Eric5,the"run window" ,the 
command line of my operating 
system can input Chinese.
msg456 (view) Author: detlev Date: 2014-01-12.14:42:42
If even the command line cannot accept Chinese characters, it is a configuration 
problem of your system and not an issue with eric. I'll close this issue. If you 
resolve your system configuration and everything else works fine and the issue is 
still present in eric, please reopen it.
msg455 (view) Author: DEAGS3000 Date: 2014-01-12.11:37:48
I've tried all these you said,all of them--even the commandline can't input 
Chinese characters.
msg454 (view) Author: detlev Date: 2014-01-12.11:20:07
Did you configure the encodings correctly (Python config page)? Does this happen 
for all input controls or just the editor? If it is just for the editor, does the 
QScintilla demo application (simple editor) work?
msg453 (view) Author: DEAGS3000 Date: 2014-01-12.11:17:26
Well,when I tried to input Chinese characters,there was nothing happen.....I 
pressed my 
keyboard,but there's no character do appear.When I try to input English 
letters,they 
will appear in Eric at once........Please ignore my terrible English ...
msg451 (view) Author: detlev Date: 2014-01-12.11:01:05
What happens when you try to input Chinese characters? Please be a bit more 
descriptive.

I think it worked in the past, when some Chinese guy used eric and contribute 
the Chinese translations. Further on, eric seems to be used much in China 
because China is at the top of the downloads.
msg450 (view) Author: DEAGS3000 Date: 2014-01-12.06:00:26
I can input English in Eric5,but can't input Chinese
History
Date User Action Args
2014-05-05 16:48:36detlevsetstatus: open -> closed
resolution: rejected
messages: + msg495
message_count: 14.0 -> 15.0
2014-05-05 15:08:58shanhusetpriority: normal -> urgent
message_count: 13.0 -> 14.0
messages: + msg494
2014-05-05 14:26:31shanhusetfiles: + 120140505222524.png
nosy: + shanhu
messages: + msg493
message_count: 12.0 -> 13.0
2014-01-26 15:03:55detlevsetmessage_count: 11.0 -> 12.0
messages: + msg464
2014-01-26 14:26:19DEAGS3000setmessage_count: 10.0 -> 11.0
messages: + msg463
2014-01-26 09:56:37detlevsetmessage_count: 9.0 -> 10.0
messages: + msg462
2014-01-25 07:31:13DEAGS3000setmessage_count: 8.0 -> 9.0
messages: + msg461
2014-01-13 17:25:49detlevsetmessage_count: 7.0 -> 8.0
resolution: rejected -> (no value)
messages: + msg458
2014-01-13 12:00:12DEAGS3000setstatus: closed -> open
message_count: 6.0 -> 7.0
messages: + msg457
2014-01-12 14:42:42detlevsetstatus: open -> closed
resolution: rejected
messages: + msg456
message_count: 5.0 -> 6.0
2014-01-12 11:37:48DEAGS3000setmessage_count: 4.0 -> 5.0
messages: + msg455
2014-01-12 11:20:08detlevsetmessage_count: 3.0 -> 4.0
messages: + msg454
2014-01-12 11:17:26DEAGS3000setmessage_count: 2.0 -> 3.0
messages: + msg453
2014-01-12 11:16:47DEAGS3000setmessage_count: 3.0 -> 2.0
messages: - msg452
2014-01-12 11:16:16DEAGS3000setmessage_count: 2.0 -> 3.0
messages: + msg452
2014-01-12 11:01:05detlevsetmessage_count: 1.0 -> 2.0
messages: + msg451
2014-01-12 10:58:38detlevsetstatus: new -> open
assignedto: detlev
nosy: + detlev
2014-01-12 06:00:26DEAGS3000create