eric ide

Issue133

Classification
Title: pyflakes python3
Type: behavior Product: eric5 snapshot
Process
Priority:    
Status: closed Resolution: fixed
Superseder: Nosy List: bcone, detlev
Assigned to: Keywords:

Created on 2014-05-09.16:40:12 by bcone, last changed by bcone.

Messages (3.0)
msg498 (view) Author: bcone Date: 2014-05-10.11:05:37
Yes, I have last snapshot 5.4.3 but I download only the 3 pyflakes new file (for
python3) form mercurial 5.4.4 repository
http://die-offenbachs.homelinux.org:48888/hg/eric5/rev/d608f3f42d71 (->file ->raw)
and the problem IS SOLVED
I Confirm CLOSED.
Thank a lot
msg497 (view) Author: detlev Date: 2014-05-10.09:52:12
Has already been fixed. The fix will be part of eric 5.4.4.
msg496 (view) Author: bcone Date: 2014-05-09.16:40:12
#! /usr/bin/env python3
#-*- coding: UTF-8 -*-
def test(**foo):
    print(foo)

# in This code I see an unespected warnig message "undefined foo" on line:
print(foo). in the equivalent code in python2, there are no warning for line:
print foo
History
Date User Action Args
2014-05-10 11:05:37bconesetpriority: normal ->
message_count: 2.0 -> 3.0
messages: + msg498
2014-05-10 09:52:12detlevsetstatus: new -> closed
resolution: fixed
messages: + msg497
message_count: 1.0 -> 2.0
nosy: + detlev
2014-05-09 16:40:12bconecreate