eric ide

Issue175

Classification
Title: Anaconda with Eric
Type: behavior Product: eric6
Process
Priority: urgent    
Status: closed Resolution: rejected
Superseder: Nosy List: balakumars, detlev
Assigned to: detlev Keywords:

Created on 2015-02-16.20:50:44 by balakumars, last changed by detlev.

Messages (3.0)
msg667 (view) Author: detlev Date: 2015-04-30.17:44:21
I just installed Anaconda on Linux and tried to install eric. The issue could be 
reproduced. The source of the issue is an incomplete Anaconda package. It is 
missing QScintilla and the QScintilla Python bindings. That is not an eric issue. 
Please report to the Anaconda maintainers.
msg649 (view) Author: detlev Date: 2015-02-17.16:03:06
Please try the following in a Python console window.

from PyQt5 import Qsci     (or from PyQt4 import Qsci)

If that shows an issue please get the installation right.
msg648 (view) Author: balakumars Date: 2015-02-16.20:50:44
Hi One of the fastest ways of setting up eric in Windows is installing Anaconda python and then eric using it.  
Anaconda comes with all prerequisites of eric including qt, sip and scintilla and I had no issues doing that in Windows.
But when I tried the same in OSX it failed with below error.  
Looks like this error can happen in regular installation as mentioned in below link.
https://gist.github.com/jimk/2563701
Sorry, please install QScintilla2 and
 it's PyQt4 wrapper.
 Error: cannot import name Qsci

Looking for guidance here.
History
Date User Action Args
2015-04-30 17:44:21detlevsetstatus: pending -> closed
resolution: rejected
messages: + msg667
message_count: 2.0 -> 3.0
2015-03-08 17:23:52detlevsetstatus: open -> pending
2015-02-17 16:03:06detlevsetstatus: new -> open
assignedto: detlev
messages: + msg649
message_count: 1.0 -> 2.0
nosy: + detlev
2015-02-16 20:50:44balakumarscreate