eric ide

Issue183

Classification
Title: Eric 6.0.9 Crash when press dropdown QDateEdit
Type: crash Product: eric6
Process
Priority: urgent    
Status: closed Resolution: wont fix
Superseder: Nosy List: detlev, sukitlek
Assigned to: detlev Keywords:

Created on 2015-09-07.02:36:24 by sukitlek, last changed by detlev.

Files
File Name Uploaded Description Remove
FinMainForm.py sukitlek, 2015-09-08.04:27:02
FinMainForm.ui sukitlek, 2015-09-08.04:27:33
PyFin.pyw sukitlek, 2015-09-08.04:25:48
Ui_FinMainForm.py sukitlek, 2015-09-08.04:26:29
eric6crash.ogg sukitlek, 2015-09-07.02:36:24 Video showing the point of craching.
Messages (7.0)
msg686 (view) Author: detlev Date: 2015-09-08.16:40:12
The issue is caused by the X-Window server (or Qt). When the calendar popup is 
requested, it is created and want to gain exclusive focus. At the same time the 
editing finished signal is sent and that fires the breakpoint. This causes eric to 
request the mouse and keyboard inputs and we have a deadlock situation. The same 
happens, when setting a breakpoint in a menu handling function. This situation 
does not happen on every OS (e.g. doesn't happen on Windows). Therefore I don't 
consider it an eric issue. However, if a workaround is known, I am happy to 
implement it.
msg685 (view) Author: sukitlek Date: 2015-09-08.04:27:33
Sample 4
msg684 (view) Author: sukitlek Date: 2015-09-08.04:27:01
Sample 3
msg683 (view) Author: sukitlek Date: 2015-09-08.04:26:29
Sample 2
msg682 (view) Author: sukitlek Date: 2015-09-08.04:25:48
Sample Code 1.
msg680 (view) Author: detlev Date: 2015-09-07.17:12:52
Please upload a small self contained sample exhibiting this issue and the traceback 
you get with your code. Currently I am not able to reproduce the issue.
msg679 (view) Author: sukitlek Date: 2015-09-07.02:36:24
If I did a breakpoint in the line command within the on_???_editingFinished()
and run program by pressing shift+F5, the eric program will crash if I press the
dropdown icon on that ??? QDateEdit.

My computer is Linux 17.3 and the version from <show version> of eric program are:
Python 3.4.0
Qt 4.8.6
PyQt 4.10.4
sip 4.15.5
QScintilla 2.8.1
WebKit 537.21
eric6 6.0.9 (rev. 1d7d42500f54)

I tested with previous version of eric back to version 6.0.0. There was the same
crash.

The video I send was showing what I did before crash. I could not show until
crash occur. If I edit the QDateEdit in edit line, it's find. But don't press
dropdown icon.
History
Date User Action Args
2015-09-08 16:40:12detlevsetstatus: open -> closed
resolution: wont fix
messages: + msg686
message_count: 6.0 -> 7.0
2015-09-08 04:27:33sukitleksetfiles: + FinMainForm.ui
message_count: 5.0 -> 6.0
messages: + msg685
2015-09-08 04:27:02sukitleksetfiles: + FinMainForm.py
message_count: 4.0 -> 5.0
messages: + msg684
2015-09-08 04:26:29sukitleksetfiles: + Ui_FinMainForm.py
message_count: 3.0 -> 4.0
messages: + msg683
2015-09-08 04:25:48sukitleksetfiles: + PyFin.pyw
message_count: 2.0 -> 3.0
messages: + msg682
2015-09-08 04:24:14sukitleksettitle: Eric 6.0.9 Crach when press dropdown QDateEdit -> Eric 6.0.9 Crash when press dropdown QDateEdit
2015-09-07 17:12:52detlevsetmessage_count: 1.0 -> 2.0
messages: + msg680
2015-09-07 17:11:25detlevsetstatus: new -> open
assignedto: detlev
nosy: + detlev
2015-09-07 02:36:24sukitlekcreate