eric ide

Issue223

Classification
Title: installing eric6 on windows 10
Type: feature request Product: eric6
Process
Priority: urgent    
Status: closed Resolution: rejected
Superseder: Nosy List: Ramese10, detlev
Assigned to: Keywords:

Created on 2017-02-09.21:12:38 by Ramese10, last changed by detlev.

Files
File Name Uploaded Description Remove
Capture.PNG Ramese10, 2017-02-09.21:12:38
Messages (2.0)
msg834 (view) Author: detlev Date: 2017-02-10.17:09:21
This is not a bug or feature request but simply some questions. Here are the 
answers.

1. The eric distribution archive does neither contain Python nor PyQt. These 
have to be installed before eric can be.

2. The easy PyQt installation procedure is described in the eric README file 
contained in the distribution archive. It is simply:
pip install qscintilla
This command installs PyQt5 and sip as well because these are dependencies.

3. In order to develop PyQt scripts you have to install Qt separately (the tools 
are not a part of the PyQt5 wheel installed with the command above).
msg833 (view) Author: Ramese10 Date: 2017-02-09.21:12:38
I have windows 10 64 bit and installed python 3.6.  when I extract eric6 it
states no pyqt5 and installation stops.  I have download pyqt5.zip when
unzipping where do I install it.  

Also does eric6 contain python 3.6 or can python be installed separately as I
have done
History
Date User Action Args
2017-02-10 17:09:21detlevsetstatus: new -> closed
resolution: rejected
messages: + msg834
message_count: 1.0 -> 2.0
nosy: + detlev
2017-02-09 21:12:38Ramese10create