eric ide

Issue239

Classification
Title: Eric 6 installation fails: "Sorry, please install PyQt5"
Type: behavior Product: eric6
Process
Priority: urgent    
Status: closed Resolution: rejected
Superseder: Nosy List: WXB13, detlev
Assigned to: detlev Keywords:

Created on 2017-05-08.02:15:37 by WXB13, last changed by detlev.

Files
File Name Uploaded Description Remove
Eric installation error - PyQt5 not installed.png WXB13, 2017-05-08.02:15:37 Eric installation terminal window
Messages (2.0)
msg888 (view) Author: detlev Date: 2017-05-08.15:50:44
According to the screenshot some DLL cannot be found. Please make sure, that the 
Python interpreter used to install eric is the same used to install PyQt5, 
QScintilla and sip.
msg887 (view) Author: WXB13 Date: 2017-05-08.02:15:37
I get a "Sorry, please install PyQt5" message when running "python install.py" even though 
PyQt5 is already installed.

Environment:
- Windows 8.1 Pro 64 bit
- Python 3.5.2
- Qt 5.80

Steps taken:
- Installed Qt 5.80.
- Installed QScintilla via "pip install QScintilla"; this installed dependencies sip & PyQt5.
- Ran "python install.py" from the directory into which the eric6 download was unzipped.
History
Date User Action Args
2017-05-14 13:35:20detlevsetstatus: open -> closed
resolution: rejected
2017-05-08 15:50:44detlevsetstatus: new -> open
assignedto: detlev
messages: + msg888
message_count: 1.0 -> 2.0
nosy: + detlev
2017-05-08 02:15:37WXB13create