eric ide

Issue241

Classification
Title: Segmentation Fault on startup
Type: crash Product: eric6
Process
Priority: critical    
Status: closed Resolution: rejected
Superseder: Nosy List: Mike_S, detlev
Assigned to: Keywords:

Created on 2017-07-26.16:20:20 by Mike_S, last changed by detlev.

Files
File Name Uploaded Description Remove
eric6_seg_fault_report.txt Mike_S, 2017-07-26.16:20:20 Text file of paste from eric6 installation
Messages (4.0)
msg896 (view) Author: detlev Date: 2017-07-30.15:41:18
I installed Anaconda3 4.4.0 on my Mint 18.2 VM. As Anaconda3 doesn't include QScintilla I 
installed it via "pip install qscintilla". During this process I recognized, that a new PyQt5 
and sip was installed. The issue seems to be with this mixed installation. eric6 crashes 
as soon as the QScintilla package is imported. Sorry, that is outside my scope.

You may consider installing eric6 in a Python virtual environment (venv, virtualenv). That 
works fine over here as well.
msg895 (view) Author: detlev Date: 2017-07-26.16:43:07
Btw, it starts fine over here on Mint 18.2 with the default Python 3 interpreter.
msg894 (view) Author: detlev Date: 2017-07-26.16:29:45
Are you sure that the default python used to install eric is the Anaconda one? Such 
segfault usually are caused by a mix and match of libraries (e.g. PyQt). eric is 
written in pure Python.
msg893 (view) Author: Mike_S Date: 2017-07-26.16:20:20
I installed eric6 several times and always got a segmentation fault on startup.
I am installing to a Linux Mint (17.3) Anaconda3 setup using the Python3.6.1 of
Anaconda to do so.
Attached is the record of the most recent installation attempt along with the
first attempted usage of eric6.
History
Date User Action Args
2017-07-30 15:41:18detlevsetstatus: new -> closed
resolution: rejected
messages: + msg896
message_count: 3.0 -> 4.0
2017-07-26 16:43:07detlevsetmessage_count: 2.0 -> 3.0
messages: + msg895
2017-07-26 16:29:45detlevsetmessage_count: 1.0 -> 2.0
nosy: + detlev
messages: + msg894
2017-07-26 16:20:20Mike_Screate