eric ide

Issue275

Classification
Title: Install Eric6 18.06 installation fails: Missing QtWebEngineWidgets, QtWebKitWidgets
Type: crash Product: eric6
Process
Priority: high    
Status: closed Resolution: rejected
Superseder: Nosy List: detlev, mrichmon
Assigned to: Keywords:

Created on 2018-07-04.16:49:04 by mrichmon, last changed by mrichmon.

Files
File Name Uploaded Description Remove
eric6.png mrichmon, 2018-07-04.16:49:04 Eric6.png shows error message from install.py.
Messages (4.0)
msg1037 (view) Author: mrichmon Date: 2018-07-05.00:34:07
I see.  I did as you suggested.  Worked great.  Thank you.
msg1036 (view) Author: detlev Date: 2018-07-04.16:59:06
This is not an eric6 issue. As of PyQt5 5.11 the Windows wheels for 32-bit Python 
don't include QtWebEngine anymore and QtWebKit is no part of Qt anymore. The best 
solution would be to install 64-bit Python and redo the PyQt5 and other tools 
installation. That works for me on my Windows 7 and 10 VMs.
msg1035 (view) Author: mrichmon Date: 2018-07-04.16:58:07
Eric6 version 17.01 install works!!
msg1034 (view) Author: mrichmon Date: 2018-07-04.16:49:04
Trying to install Eric 6 on Windows 10.  Installed Python 3.7.0.  Installed 
Qt (free version). Ran pip install QScintilla to install QScintilla-2.10.7, 
PyQT5(5.11.2), PyQt5-sip-4.19.11.  Attempt to install Eric 6 18.06 using 
"install.py" and get an error message "Sorry, please install 
PyQt5.QtWebEngineWidgets or PyQt5.QtWebKitWidgets".  Tried to install Eric 6 
18.01 with same result.
History
Date User Action Args
2018-07-05 00:34:07mrichmonsetmessage_count: 3.0 -> 4.0
messages: + msg1037
2018-07-04 16:59:06detlevsetstatus: new -> closed
resolution: rejected
messages: + msg1036
message_count: 2.0 -> 3.0
nosy: + detlev
2018-07-04 16:58:07mrichmonsetmessage_count: 1.0 -> 2.0
messages: + msg1035
2018-07-04 16:49:04mrichmoncreate