eric ide

Issue285

Classification
Title: Windows Eric6 doesn't start after upgrade of pyqt5 to 5.11
Type: crash Product: eric6
Process
Priority: critical    
Status: closed Resolution: works for me
Superseder: Nosy List: Ludwig49, detlev
Assigned to: Keywords:

Created on 2018-10-21.11:15:53 by Ludwig49, last changed by Ludwig49.

Messages (3.0)
msg1070 (view) Author: Ludwig49 Date: 2018-10-21.15:59:48
After 'pip3 install --upgrade QScintilla' all works fine. Thank you!
msg1069 (view) Author: detlev Date: 2018-10-21.12:25:40
Did you update QScintilla with 'pip3 install --upgrade QScintilla'? Upgrading 
PyQt5 doesn't force a QScintilla upgrade and this could lead to the observation. 
If after doing so the issue is gone, please close this report.
msg1067 (view) Author: Ludwig49 Date: 2018-10-21.11:15:53
I upgraded Pyqt5 by using pip3 install --upgrade pyqt5. After that Eric6 
failed to start with the following message:
Traceback (most recent call last):
  File "C:\Users\Werner\AppData\Local\Programs\Python\Python35\Lib\site-
packages\eric6\eric6.pyw", line 14, in <module>
    main()
  File "C:\Users\Werner\AppData\Local\Programs\Python\Python35\Lib\site-
packages\eric6\eric6.py", line 295, in main
    if not Globals.checkBlacklistedVersions():
  File "C:\Users\Werner\AppData\Local\Programs\Python\Python35\Lib\site-
packages\eric6\Globals\__init__.py", line 145, in checkBlacklistedVersions
    from PyQt5.Qsci import QSCINTILLA_VERSION_STR
ValueError: PyCapsule_GetPointer called with incorrect name
History
Date User Action Args
2018-10-21 16:00:34Ludwig49setstatus: open -> closed
resolution: works for me
2018-10-21 15:59:48Ludwig49setmessage_count: 2.0 -> 3.0
messages: + msg1070
2018-10-21 12:25:40detlevsetstatus: new -> open
nosy: + detlev
messages: + msg1069
message_count: 1.0 -> 2.0
2018-10-21 11:15:53Ludwig49create