eric ide

Issue325

Classification
Title: Compilation of form file failed
Type: behavior Product: eric6
Process
Priority: urgent    
Status: closed Resolution: invalid
Superseder: Nosy List: Yetib, detlev
Assigned to: Keywords:

Created on 2020-04-25.09:41:52 by Yetib, last changed by detlev.

Messages (3.0)
msg1203 (view) Author: detlev Date: 2020-05-02.09:37:44
Message from Yetib:

I can only guess that there may be a problem with ALL PyQtTools (all of them showed 
(unknown) in Show External Tools), caused by a version issue. Indeed, PyqtTools requires 
5.13 version of Qt, while Eric6 installs 5.14.2 (due to WebEngine...)

Then PyQt5-tools should be installed BEFORE Eric6.

Note: PyQt5-tools is a Windows only package.
msg1199 (view) Author: detlev Date: 2020-04-25.11:10:37
1. The pyuic5 issue could be related to the PyQt5 version. Please provide this 
information. The forms compilation works for me on several systems.

2. The "from .Ui_filename import UI_mainWindow" is a relative import. The '.' means to 
import from that file in the same package. A '..' would mean to look in the parent package 
and so on.
msg1198 (view) Author: Yetib Date: 2020-04-25.09:41:52
Hi, since version 20.3 (and 20.4), I get the popup "Compilation of form file 
failed" when invoking pyuic5 from right click popup menu. No further 
information. Compilation from a shell works fine however. Launching QtDesigner 
is OK. I switched to Python 3.7.7, I use WinPython distrib on Windows 10.
Another point looks weird: When I "generate dialog code" from the same menu, 
the import line looks like this
from .Ui_filename import UI_mainWindow
why is there a dot preceding the module name ?
I reviewed deeply all configuration of Eric6, project etc...but no idea.
please help, this is a very useful feature.
History
Date User Action Args
2020-05-02 09:37:44detlevsetstatus: open -> closed
resolution: invalid
messages: + msg1203
message_count: 2.0 -> 3.0
2020-04-25 11:10:37detlevsetstatus: new -> open
nosy: + detlev
messages: + msg1199
message_count: 1.0 -> 2.0
2020-04-25 09:41:52Yetibcreate