eric ide

Issue326

Classification
Title: Installation error - windows 10 and Eric IDE
Type: crash Product: eric6
Process
Priority: critical    
Status: closed Resolution: invalid
Superseder: Nosy List: davidjgoodman, detlev
Assigned to: Keywords:

Created on 2020-04-27.20:37:40 by davidjgoodman, last changed by detlev.

Messages (2.0)
msg1201 (view) Author: detlev Date: 2020-04-28.15:05:50
This is not an eric issue but caused by the operating system. There are two possibilities 
I am aware of.

1. There seems to be a Windows configuration to disable the path length limit of 256 
chracters. Unfortunately I don't know which one it is.
2. Create a Python virtual environment (e.g. C:\Users\David\eric_env) and install eic in 
there. This has the advantage, that you can have different versions of Python and/or the 
packages (like PyQt5) on your system. Details about this may be found on the eric web 
site.
msg1200 (view) Author: davidjgoodman Date: 2020-04-27.20:37:40
When trying to install Eric-ide on a windows 10 achine the installtion fails from pip and install.py downloads. 
Tracing the error appears to be with filename length. 

The error message provided is 

ERROR: Could not install packages due to an EnvironmentError: [Errno 2] No such file or directory: 'C:\\Users\\David\\AppData\\Local\\Packages\\PythonSoftwareFoundation.Python.3.8_qbz5n2kfra8p0\\LocalCache\\local-packages\\Python38\\site-packages\\eric6\\Documentation\\Source\\eric6.Plugins.WizardPlugins.QRegularExpressionWizard.QRegularExpressionWizardCharactersDialog.html'

checking the relavent directory finds the file
eric6.Plugins.WizardPlugins.QRegExpWizard.QRegExpWizardCharactersDialog.html

I cant rename it as the filename is too long for windows.

The pip install manifest needs to replect the correct filename but I dont know  how to change it.
History
Date User Action Args
2020-04-28 15:05:50detlevsetstatus: new -> closed
resolution: invalid
messages: + msg1201
message_count: 1.0 -> 2.0
nosy: + detlev
2020-04-27 20:37:40davidjgoodmancreate