eric ide

Issue355

Classification
Title: Insert Text in editor and shell
Type: behavior Product: eric6
Process
Priority: critical    
Status: closed Resolution: works for me
Superseder: Nosy List: detlev, rfrerich
Assigned to: Keywords:

Created on 2020-10-23.10:39:51 by rfrerich, last changed by detlev.

Files
File Name Uploaded Description Remove
Preferences.ini rfrerich, 2020-10-23.17:03:11
eric_editor_shell.png rfrerich, 2020-10-23.10:39:51
Messages (15.0)
msg1325 (view) Author: detlev Date: 2020-11-27.16:49:35
I could not observe such a strange behaviour at any time. Either it is caused by some 
corner case situation not present on any of my development machines (various Linuxes, 
Windows 7 and 10, macOS) or it is within the QScintilla editor widget. I suggest to post a 
report to the QScintilla mailing list.
msg1320 (view) Author: rfrerich Date: 2020-10-25.16:10:47
Additional:
When i go back to eric, there is no reaktion from preferences. I have to restart eric.
Also select and deselect "Use monospaced as default" works only after a restart.
msg1319 (view) Author: rfrerich Date: 2020-10-25.16:03:16
If i select "Use monospaced as default" in eric and start then the MiniEditor, it shows the same behavior. So i think, that is another problem from QScintilla.
msg1318 (view) Author: detlev Date: 2020-10-25.12:45:16
The editor doesn't allow to change any settings. It uses the identical configuration to the 
eric IDE. That means, if you want or have to change some settings, you must do it in eric 
and restart the Mini Editor.
msg1317 (view) Author: rfrerich Date: 2020-10-25.10:43:35
In eric6_editor you used the MinEditor. In MiniEditor you imported Preferences. How can i use the preferences  in the menu. I need to change the font for my testing.
msg1316 (view) Author: detlev Date: 2020-10-24.10:47:46
You could try the example editor that is part of the QScintilla package (although this is 
very basic). You could also try the eric6_editor script, which opens a standalone editor 
based on QScintilla.
msg1315 (view) Author: rfrerich Date: 2020-10-24.10:44:55
Is it possible to make a simple editor with QScintilla to test this behavior.
msg1314 (view) Author: detlev Date: 2020-10-24.09:12:00
The configuration page has been fixed. The change will be in the next release. 
Unfortunately I don't have the slightes idea, what could cause the observed behavior.
msg1313 (view) Author: rfrerich Date: 2020-10-24.08:28:55
I changed All Fonts for the highlighter style to monospaced, but there is still the same problem, when i select "Use monospaced as default". Additional i have to restart eric to change the behavior. 
Additional information:
In configure syntax highlighting the selectetd font is not visible. You have to scroll far down. The font selection button is at the bottom.
msg1312 (view) Author: detlev Date: 2020-10-23.17:22:44
Please try to set monospaced fonts for the Python3 highlighter style.
msg1311 (view) Author: rfrerich Date: 2020-10-23.17:03:11
No but in Editor/Style. I added my Preferences.

I will logout for today.

Thank you
msg1310 (view) Author: detlev Date: 2020-10-23.16:53:33
I have this option active and cannot see the described behavior. It must be something else 
or a combination. Do you have monospace fonts configured for the syntax highlighter styles?
msg1309 (view) Author: rfrerich Date: 2020-10-23.16:08:12
I found the reason for this behavior. If i deselect "Use monospaced as default" in "Editor/Style/Fonts" it works in the editor.
For the shell i could not find a solution.
QScintilla seems to make several problems.
msg1308 (view) Author: detlev Date: 2020-10-23.15:31:29
I never ever saw such a weird behavior and I have absolutely no idea, what could cause it. 
As such a behavior would be caused by the QScintilla editor widget I suggest to post a 
message in the QScintilla mailing list.
msg1307 (view) Author: rfrerich Date: 2020-10-23.10:39:51
When i insert text in the editor or the shell there are blnaks inserted and it is hard to find the real cursor position. Until today i had this problen only in the shell. 
In the example you see the cursor in a left position(first line). When i move the cursor to the right, the editor inserts blanks(second line).
In the third line i just inserted numberes and the more numbers are inserted, the more blanks appear at the end.

With this behavior it is not possible to edit a script.
I have this problem only with a new script. At this time my older script dont show this behavior.
History
Date User Action Args
2020-11-27 16:49:35detlevsetstatus: new -> closed
resolution: works for me
messages: + msg1325
message_count: 14.0 -> 15.0
2020-10-25 16:10:47rfrerichsetmessage_count: 13.0 -> 14.0
messages: + msg1320
2020-10-25 16:03:16rfrerichsetmessage_count: 12.0 -> 13.0
messages: + msg1319
2020-10-25 12:45:16detlevsetmessage_count: 11.0 -> 12.0
messages: + msg1318
2020-10-25 10:43:35rfrerichsetmessage_count: 10.0 -> 11.0
messages: + msg1317
2020-10-24 10:47:46detlevsetmessage_count: 9.0 -> 10.0
messages: + msg1316
2020-10-24 10:44:55rfrerichsetmessage_count: 8.0 -> 9.0
messages: + msg1315
2020-10-24 09:12:00detlevsetmessage_count: 7.0 -> 8.0
messages: + msg1314
2020-10-24 08:28:55rfrerichsetmessage_count: 6.0 -> 7.0
messages: + msg1313
2020-10-23 17:22:44detlevsetmessage_count: 5.0 -> 6.0
messages: + msg1312
2020-10-23 17:03:11rfrerichsetfiles: + Preferences.ini
message_count: 4.0 -> 5.0
messages: + msg1311
2020-10-23 16:53:33detlevsetmessage_count: 3.0 -> 4.0
messages: + msg1310
2020-10-23 16:08:12rfrerichsetmessage_count: 2.0 -> 3.0
messages: + msg1309
2020-10-23 15:31:29detlevsetmessage_count: 1.0 -> 2.0
nosy: + detlev
messages: + msg1308
2020-10-23 10:39:51rfrerichcreate