eric ide

Issue410

Classification
Title: Error after start of new installed Eric 7
Type: crash Product: eric7
Process
Priority: critical    
Status: closed Resolution: rejected
Superseder: Nosy List: detlev, rfrerich
Assigned to: Keywords:

Created on 2021-12-14.09:10:47 by rfrerich, last changed by detlev.

Messages (5.0)
msg1562 (view) Author: detlev Date: 2021-12-15.16:39:43
If eric7 is installed in parallel or as a replacement for eric6 it will import the 
preferences automatically. Usually, you will find the preferences in ~/.config/Eric6 
directory. 

If you did a fresh OS install, just move this directory over from your old and keep the 
name. In that case eric7 will detect it and convert it to an eric7 prefernces. However, this 
process happens only, if eric7 has not been configured (i.e. run) yet.

The other stuff is located in the ~/.eric6 directory. Just import the files into you need 
into eric7. Sorry, if this causes some work, but I thought it would be better to start with 
a fairly fresh setup than mover everything over.
msg1560 (view) Author: rfrerich Date: 2021-12-15.13:55:52
How can i move my preferences, templates, ... to a new linux version. I think eric7_post_install only works, when it finds an older verion.
msg1559 (view) Author: rfrerich Date: 2021-12-15.13:41:15
I tried eric7 on linux mint and it works. So will change to mint.
msg1556 (view) Author: detlev Date: 2021-12-14.18:52:18
Thanks for reporting this issue. As the stacktrace indicates, the root cause is within the 
libgssapi_krb5.so.2 library, which is a system library of your system. There is nothing I 
can do about it.
msg1554 (view) Author: rfrerich Date: 2021-12-14.09:10:47
After installation of Eric 7, i get this messages:
~/Daten/Python/Eric/eric6-21-12_env/bin$ ./eric7
Error in sys.excepthook:
Traceback (most recent call last):
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 783, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/Utilities/__init__.py", line 63, in <module>
    import Preferences
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/Preferences/__init__.py", line 41, in <module>
    from EricNetwork.EricFtp import EricFtpProxyType
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/EricNetwork/__init__.py", line 10, in <module>
    from PyQt6.QtNetwork import QAbstractSocket, QHostAddress
ImportError: /lib/x86_64-linux-gnu/libgssapi_krb5.so.2: undefined symbol: krb5_ser_context_init, version krb5_3_MIT

Original exception was:
Traceback (most recent call last):
  File "./eric7", line 8, in <module>
    sys.exit(main())
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/eric7.py", line 311, in main
    import Preferences
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/Preferences/__init__.py", line 41, in <module>
    from EricNetwork.EricFtp import EricFtpProxyType
  File "/home/tuxuser/Daten/Python/Eric/eric6-21-12_env/lib/python3.8/site-packages/eric7/EricNetwork/__init__.py", line 10, in <module>
    from PyQt6.QtNetwork import QAbstractSocket, QHostAddress
ImportError: /lib/x86_64-linux-gnu/libgssapi_krb5.so.2: undefined symbol: krb5_ser_context_init, version krb5_3_MIT

Regards

R. Frerichs
History
Date User Action Args
2021-12-15 16:39:43detlevsetmessage_count: 4.0 -> 5.0
messages: + msg1562
2021-12-15 13:55:52rfrerichsetmessage_count: 3.0 -> 4.0
messages: + msg1560
2021-12-15 13:41:15rfrerichsetmessage_count: 2.0 -> 3.0
messages: + msg1559
2021-12-14 18:52:18detlevsetstatus: new -> closed
resolution: rejected
messages: + msg1556
message_count: 1.0 -> 2.0
nosy: + detlev
2021-12-14 09:10:47rfrerichcreate